Excel: nb.si.ens() ~ countifs()

Comme toutes les autres fonctions les plus utilisées, ajouter un .si ou if [comme dans somme.si(), moyenne.si(), nb.si(), …] lui permet de faire une operation à une condition, mais ajouter un .si.ens ou ifs [comme dans somme.si.ens(), moyenne.si.ens(), nb.si.ens(), …] lui permet de faire une opération à multiples conditions.

Sa forme est:

=NB.SI.ENS(vecteur_test_1;valeur_test_1[;vecteur_test_2;valeur_test_2; …;vecteur_test_n;valeur_test_n])

Cela signifie que chaque vecteur a sa valeur contre laquelle on va tester.

  • Un vecteur est une plage des données. Ex. D12:D21;
  • Une valeur peut être un texte, un nombre, une date,… ou une référence cellulaire. Pour comparer on utilise les opérateurs de comparaison (= égal, > supérieur, >= supérieur ou égal, < inférieur, <= inférieur ou égal, <> inégale ou différent);
  • = égal peut être omis.
  • Les autres opérateurs doivent être placés entre “”. Ex. “<12”, “>=8”;
  • S’il s’agit d’une combinaison entre operateur et référence cellulaire, l’opérateur sera toujours placé entre “” suivi de & et la cellule. Ex. “<=” & B5, “<>” & D34;
  • L’opérateur de concaténation ‘&’ sert à relier les opérants.

Notre cas nous impose 3 conditions

  • Seul de sexe masculin : “M” ou “=M”;
  • Âgé de moins de 25 ans : “<25”;
  • De niveau d’étude inférieur à 14 : “<14”;

Là sont les 3 valeur_test à utilisé. Ainsi nous aurons pour chaque cas:

  1. Sexe sur colonne D: Vecteur_test_1;valeur_test_1 : D12:D21;”=M”
  2. Âgé sur colonne C: vecteur_test_2;valeur_test_2 : C12:C21;”<25″
  3. Niveau d’étude sur colonne E : vecteur_test_3;valeur_test_3 : E12:E21;”<14″

En somme:

=NB.SI.ENS(D12:D21;”=M”;C12:C21;”<25″;E12:E21;”<14″)

En anglais:

=COUNTIFS(D12:D21,”=M”,C12:C21,”<25″,E12:E21,”<14″)

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s