EXCEL: MOYENNE.SI() ~ AVERAGEIF()

Problématique

On veut calculer la moyenne de certains éléments du tableau par rapport à des caractéristiques bien définies.

Pour cela il faut utiliser la fonction MOYENNE.SI(). ou AVERAGEIF() en Anglais.

Utilisons moyenne.si() à trois paramètres:

  • Param1: le vecteur dans lequel on va comparer. Ici prenons la colonne de ID comme elle est spécifique à chaque travailleur. Ainsi on a : $B$8:$B$13;
  • Param2: la valeur à comparer. Ainsi on a B18. Cette valeur va rester relative;
  • Param3: le vecteur où il y a des valeurs à utiliser dans le calcul de la moyenne. Ainsi on a: $D$8:$D$13



    EN RÉSUMÉ

    Dans la cellule D18 la formule sera : 

    • En français: =MOYENNE.SI($B$8:$B$13;B18;$D$8:$D$13)
    • En anglais: =AVERAGEIF($B$8:$B13,B18,$D$8:$D$13)

    La formule de la cellule D18 sera copiée dans les cellules D19 et D20.

    Le total dans D14 est une simple sommation SOMME() ~ SUM().

    ATTENTION:

    MOYENNE.SI() n’est disponible qu’à partir de Excel 2007. Pour les versions antérieures il existe des alternatifs:

    • SOMME.SI()/NB.SI(): somme conditionnelle divisée par son compte conditionnel. La fonction SOMME.SI() a déjà été abordée.
    • MOYENNE(SI()): Le tout se passe dans la fonction si().  =MOYENNE(SI($B$8:$B13=B18,$D$8:$D$13)). Pour confirmer il faut appuyer sur CONTROL+SHIFT+ENTER. Si non ça ne va pas marcher.
    Advertisements

    Leave a Reply

    Fill in your details below or click an icon to log in:

    WordPress.com Logo

    You are commenting using your WordPress.com account. Log Out / Change )

    Twitter picture

    You are commenting using your Twitter account. Log Out / Change )

    Facebook photo

    You are commenting using your Facebook account. Log Out / Change )

    Google+ photo

    You are commenting using your Google+ account. Log Out / Change )

    Connecting to %s